Windows 8 и Wi-Fi адаптеры TP-Link

Похоже наткнулся на еще один баг в Windows 8, а точнее в ее поведении в отношении Wi-Fi адаптеров.
Сейчас в интернете существует целый ворох форумных дискуссий на тему того, какие же из имеющихся Wi-Fi адаптеров могут работать на новой операционной системе. Есть много жалоб. Дискуссии и жалобы небезосновательны. Windows 8 оказалась очень капризной в отношении железа, посредством которого ее коонектят к беспроводным сетям.
Я не стал исключением и тоже столкнулся с проблемой несовместимости. В моем случае камнем преткновения стали сетевые адаптеры TP-Link TL-751ND. Купив адаптеры для своего компьютера и компьютера своей жены (у которой еще стоит Windows 7 x64), я со спокойной совестью подключил адаптеры. Windows 7 затребовала драйверы, которые были ей скормлены с диска, идущего в комплекте с адаптером, после чего прекрасно увидела мои wi-fi сети и все отлично заработало.
А вот с Windows 8 оказалось все совсем непросто. Драйверы под адаптер она нашла сама в собственной библиотеке драйверов, естественно имеющие цифровую подпись Microsoft, тоесть отмеркированные как годные. Но после установки драйверов машина стала виснуть на первых же минутах работы. Причем виснуть намертво, помогает только перезагрузка по reset. После запуска машина снова зависалет, попрой даже на этапе приглашения ввода пароля, снова ресет, и так по кругу. Я пробовал менять адаптеры местами, предположив что неисправен сам адаптер. Но это не так - обе карточки работают на Windows 7, и ни одна из них на Windows 8.
На просторах англоязычного интернета нашел вопрос об адаптере TL-WN851ND, с которым у пользователя точно такие же проблемы (windows 8 freezing), и тоже пока никакого решения.

В журнале ошибок повторяются только два события
1. источник:sptd код:4 Обнаружена внутренняя ошибка в структуре данных драйвера для .
2. источник:volmgr код:46 Не удалось инициализировать аварийный дамп.

И если со второй ошибкой все понятно - машина зависает, дамп писать не получается, то ошибка sptd имеет отношение к виртуальным дискам от Daemon Tools или ему подобных, которых у меня давно не водится, и не было установлено в системе еще с Windows XP.
Далее шли уже зависимые эвенты, которые сигнализировали о незапуске служб DHCP, DNS, Net-Bios и т.д., по причине того, что присоединенное к системе устройство не работает.

В общем я пока что пойду покупать еще один сетевой адаптер для тестов, на этот раз это будет Asus PCE-N53. И буду пробовать детальнее изучить проблему.

Update:
Накопал список совместимости TP-Link и Windows 8

http://www.tp-linkru.com/common/Promo/Ru/win8compatibility/

по нему пока мой адаптер в "списке ожидания обновления драйверов". Так что скорее всего, через некоторое время ситуация будет исправлена. Попробую 781ND, который в списке стоит как совместимый.
Кстати по поводу N53 - в технической поддержке ASUS сказали что адаптер официально не поддерживается в операционной системе Windsows 8. Вот так вот.

Поделиться

Опубликовать в Facebook
Опубликовать в LiveJournal

Windows 8 и Wi-Fi адаптеры TP-Link: Один комментарий

  1. Тоже проблема с адаптером на win8, но не Tp-link, а ASUS USB N53. Стоит роутер ASUS rt-n16, поскольку он дико греется — добавил радиатор с вентилятором, китайским, жужжащим(единственный влезал в корпус)… Решил перенести его подальше и инет получать по wifi. Долго выбирал адаптер, остановился на usb n53, думал два асуса будут работать лучше чем железки от разных производителей. Подключил к ноуту с Win7, отключил встроенный приемник — все летает в два раза быстрее. Подключил к компу с Win8. Работает но с глюками. обновил прошивку выставил настройки — работает на 300мбит. Проверяю скорость инета — получение отличное, как с кабелем, но как только начинает проверять отправку — роутер rt-n16 перезагружается…чего не делал — то же самое. Решил забить на проверку, пусть хоть так работает. Но нет — 5-10 минут раздачи торрентов — перезагрузка роутера. Иногда бывает час — два нормально раздает. Роутер не греется, охлаждение работает…Настройки менял все какие мог, на какие только можно подумать что они вызывают проблему — результата ноль. Прошивку снова поменял на последнюю стабильную которой пользовался — те же пироги…поставил адаптер на ноут — пусть хоть там инет быстрее будет, у ноута стандарт G, а тут N, все же радость…

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

*

Можно использовать следующие HTML-теги и атрибуты: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>